Performance issue

Incident Report for Insuraviews

Postmortem

This incident is resolved. Between approximately 8:45 and 10:00 AM CDT, some customers experienced slow load times or timeouts on the dashboard and filing browser. The cause was a large data import that consumed more database resources than expected, which reduced capacity available to the application. We paused the import and restored normal capacity. All services are operating normally, and no data was lost or affected. We are putting safeguards in place to prevent a repeat.

Posted Sep 03, 2026 - 10:25 CDT

Resolved

This incident has been resolved.
Posted Sep 03, 2026 - 10:16 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 03, 2026 - 10:12 CDT

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 03, 2026 - 10:11 CDT

Investigating

We are currently investigating the issue
Posted Sep 03, 2026 - 09:58 CDT
This incident affected: App.